Dodge Durango Forum - Forums and Owners Club! banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everyone, I’m new to the forum and have a 2012 citadel with the 5.7. For the last few months the low light has been flashing on the dash and the vehicle gives a message to slow down below 3mph to go into Low. Today when i started the car it was already in low but the knob was still on awd and I did not switch the knob to low. I was eventually able to get the vehicle out of low but I know it is only temporary and just a matter of time before something breaks. Any ideas on what would cause this? I was told maybe the transfer case position sensor needed to be replaced and a neutral calibration done. I’m not sure where that sensor even is or how to perform that calibration. Has anyone else had this issue?
 

·
Registered
Joined
·
2 Posts
Hey everyone, I’m new to the forum and have a 2012 citadel with the 5.7. For the last few months the low light has been flashing on the dash and the vehicle gives a message to slow down below 3mph to go into Low. Today when i started the car it was already in low but the knob was still on awd and I did not switch the knob to low. I was eventually able to get the vehicle out of low but I know it is only temporary and just a matter of time before something breaks. Any ideas on what would cause this? I was told maybe the transfer case position sensor needed to be replaced and a neutral calibration done. I’m not sure where that sensor even is or how to perform that calibration. Has anyone else had this issue?
Any solution to your problem?
 

·
Registered
Joined
·
2 Posts
I had the same issue, brought durango to dealer and they scanned/flashed it, nothing found. Note that only "Low" flashing light presented, no check engine light or service AWD.
 
1 - 4 of 4 Posts
Top