Dodge Durango Forum - Forums and Owners Club! banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i recently bought a 98 durango and it came with a few probs. first, the odometer, radio, speedo, do not work. also the abs light and brake light are on. second, the ac blows cold in the back but not in the front. can anyone please help?
 

·
Registered
Joined
·
2,005 Posts
Welcome from Texas. Please be sure to search the forums. There are several posts concerning front air not blowing cold.
As for the electrical problems. I would begin by looking for a bad fuse or possibly an unplugged connector on the instrument cluster.
 

·
Administrator
2009 Dodge Challenger R/T
Joined
·
2,554 Posts
Welcome to the Z from NC! Not sure but the ABS/brake light might be caused by a bad speed sensor. May want to search on that. Glad you joined, enjoy!
 

·
Registered
Joined
·
23 Posts
the brake light only comes on if the brake fluid is low. the abs is probably a bad sensor.
and i would check fuses for the radio and stuff.
 

·
Registered
Joined
·
14 Posts
i recently bought a 98 durango and it came with a few probs. first, the odometer, radio, speedo, do not work. also the abs light and brake light are on. second, the ac blows cold in the back but not in the front. can anyone please help?
These are all the same problem.

I bet your speedo starts working at about 40+, right?

Replace the speed sensor on top of the rear differential. I just got done doing this, and both warning lights went off, and the speedo/odo started working.

The part is $35 ($40 with tax) at Napa, and it takes about 30 minutes including fumbling around because you're not familiar with the vehicle. You'll need 13mm and 14mm wrenches or sockets. And if you have a hi-lift jack, that will help by giving you more room to work between the body and the axle (jack it up by the rear bumper or tow hitch).
 
1 - 5 of 5 Posts
Top