Dodge Durango Forum - Forums and Owners Club! banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
hey guys whats going on,
i have a few questions, i have a durango on about 33's. I went mudding the other and got it stuck in a mudd hole and was in water up to the bumper, water was coming through the doors. Thats not the issue. We left the truck the running the whole time. But when we got it pulled out. The truck wouldn't shift into 2, sometimes it did but would never go into 3rd. It's a auto trans, and we even tried to shift it manually it wouldn't. We left it in my garage for a day and drove it and it shifted. But now the overdrive light brinks on and off. Think its overdrive off. Any idea on what could be the problem?
 

·
Registered
Joined
·
2,005 Posts
Sounds like you might have gotten some mud in one of the wire connectors for the transmission. I would get under it and hose it all out real good. Then try making sure all the connections are good.
When I used to wheel mine I would park it across the ditch in my front yard and put one of those oscillating water sprinklers under s it for a couple of hours.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Alright cool, thanks, i'l try that.
I took it to AAMCO and the code back being a shifting problem but they want 495 to only take it apart and look at it, thats not including whats wrong with. I though about dropping the trans fluid and replacing the fluid. I have talked to some and they say my trans is blown but i dont think thats the case. So i'l try what you said. what about a pressure washing is that to much pressure.?
 
G

·
What year? you say it shifts now but OD light blinks. Does not sound like a blown tranny. If OD is not shifting it probably an electrical thing.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top