Dodge Durango Forum - Forums and Owners Club! banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi Gang, a new guy here

I am the proud owner of a 2011 Durango Crew. New for me, I got it with 6900 miles on the clock for a smokin price. I chose the D over a used Mercedes GL. After having an S class for 8 years, I decided I didn't want to deal with the extra cost of all the stuff that can break like the air suspension. As far as I'm concerned, the new Durango is a Mercedes GL that has fewer problems and is more affordable. After driving both I can tell you that I am hard pressed to tell the difference.

That said, I love mine, but I am having one small issue. The buttons on the steering wheel that control the EVIC screen are apparently dead. Phone / VM buttons work, cruise works, just the up and down buttons for EVIC don't. I am taking to the dealer to sort out, but if any of you have encountered this or have any ideas I would love to hear from you. After lurking on this forum for a while it's clear that you the owners know more about the vehicle than some of the dealers. Thanks
 

·
Registered
Joined
·
2,005 Posts
Well, I don't have the pleasure of being the owner of a NEW Durango. But I do have a Charger with EVIC. I know that with mine the up and down buttons control different things depending on what mode you're in.
When operating the radio they change stations. When in compas mode they perform differently. And when in EVIC they do others.

Double check what mode your in when you push the up and down.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks Tymont,

Just got the word from the dealer though that the actual switch is bad. The are ordering a new one, covered under warranty of course. I will post an update to all when they put the new switch in.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top