Dodge Durango Forum - Forums and Owners Club! banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
In december my motor locked up because of oil pump problems. I had a local shop replace the motor with one from a 1997 durango that had about 60,000 miles on it.

The problem is since the motor was replaced the durango would not shft into overdrive. Had them look at this a few times. Eventually the transmission started making a noise. The shop that replaced the motor said they couldn't do transmission work. So I took it to a shop that replaced the selinoids in the transmission, after this I got a check engine light the code indicated a shift problem from 3rd to 4th selinoid in wrong location. I took it back to the shop that replaced the selinoids they indicated I needed to have the transmission reprogrammed flashed and only a dodge dealership could do this. I had this done also while there they found the cam and crank sensors where out of sync. I had that done and the fuel system cleaned because they found carbon deposits. Well the check engine light came on again with the same problem. Then a couple days later I went to back up and there was a loud pop and reverse is now gone. drive still works (although there is a loud sound like the hubs are locked in or as if it's in 4wd) 4wd will not engage though and also my o/d off light is on, on my dash.

I don't know what else to do I've but $3000 in the vehicle since the motor locked up and the transmission is worse than ever. Anyone have any ideas could there be some sort of conflict between the motor installed and the transmission. Any help or suggestions would be greatly appreciated. Thank you
 

·
Registered
Joined
·
2,005 Posts
Wow, that sounds like some frustrating crap. I don't see that installing a 97 engine would cause that type of trouble with the tranny. It seems to me like the transmisson shop screwed up on the tranny rebuild. That's where I'd be focusing my attention.
I hope you get it straightened out soon.
 
1 - 2 of 2 Posts
Top