Dodge Durango Forum - Forums and Owners Club! banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
i got a problem with my 2000 durango with 4.7l. went 4wheeling the other day when i got to my wheeling location everything was fine i went playing in the mud and after about 20-25 min i noitced a major lack in power going up hill the engine would barely go above 2000 rpm. driving back home was scarry engine made the truck vibrate, was gutless, made a fairly loud ticking noise almost sounds like a leaky exhaust from the passenger side plus the check engine light was on and flashing. i cleaned the truck at the car wash that didn't help, i also unhooked the battery and nothing, haven't really been wanting to drive it untill i had an idea of what it could be.

anybody out there possibly had the same problem???
 

·
Administrator
2009 Dodge Challenger R/T
Joined
·
2,566 Posts
If the check engine light comes back on, try this to read the codes.

1-Turn the ignition to the on position
2-Turn it back to ACC
3-Turn it back to the on position
4-Turn it back to ACC
5-Turn it back to the on position and leave it

This should be done in under 3 or 4 seconds and the codes should read out in the odometer display.

They would have been there but disconnecting the battery would have cleared them.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
i drove it around today and the check engine light came back and it flashed p0300, p0303, p0305
so looks by the codes that i got a misfiring in cylinder 3&5 so ill be changing out the spark plugs and hopefully that solves it.

would anything else cause a missfire??
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top