Dodge Durango Forum - Forums and Owners Club! banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a two week old 2012 Durango Crew with 500 miles so far. I have noticed some odd things here and there but Friday things started getting strange.

Upon returning to the car after running into a store Friday night and starting the engine the dash and headlights failed to turn on. Also could not get dome lights to turn on. Stopping the engine, getting out, locking, unlocking several times the lights finally came on but the engine light stayed on, long with the traction control light. PushIng traction control button turned that light off. While driving, though, ECO light never lit even while coasting.

Saturday after a few drives everything went back to normal. However, that night I remote started and after entering and starting to drive the front wipers came on by themselves. No matter what they would not stop or even change speeds. Could not use washer to try and protect blades. Engine light on, traction light on, no dome lights, no turn indicators, dash menu frozen, no ECO light. Ended up removing wiper fuse. Still that way today after several drives.

Will take it to dealer service tomorrow. Seems like the 'computer' needs to be reset/reloaded. Anyone ever heard of this or have any ideas?
 

·
Registered
Joined
·
949 Posts
Your the first one to have mentioned a problem like that on the '11+ models as far as I'm tracking. I never had a problem like that with my RAM nor has my roommate with his '11 Charger R/T.

Let us know what the dealership says after they hook it up to that new diagnotic system.
 

·
Registered
Joined
·
2,005 Posts
I wouldn't have thought the clockspring would affect the dash lights. who knew.
 

·
Registered
Joined
·
949 Posts
WOW! I would of never guessed that. Probably it was grounding out somewhere or there was a lose wire. Regardless. Glad to hear that it's fixed.
 

·
Registered
Joined
·
1 Posts
Electrical issues 2011 Durango

I have a 2011 Durango crew, at 1,500 miles all electronics went out including the power steering, and wipers came on. Took it to dealer who received over voltage codes but could not find anything wrong. 4 months later and about 8,000 miles, the same problem came back. Took it to another dealer, who printed out 3 pages of codes from the scan. Now I have contacted Chrysler, who has contacted dealers and I can not get a dealer nearby to take it in under warranty to correct this safety concern. One dealer told me, he can't do anything unless it's acting up as they are troubleshooting it and the codes mean nothing to him! I am getting really aggrevated with the run around!
 

·
Registered
Joined
·
59 Posts
I have a 2011 Durango crew, at 1,500 miles all electronics went out including the power steering, and wipers came on. Took it to dealer who received over voltage codes but could not find anything wrong. 4 months later and about 8,000 miles, the same problem came back. Took it to another dealer, who printed out 3 pages of codes from the scan. Now I have contacted Chrysler, who has contacted dealers and I can not get a dealer nearby to take it in under warranty to correct this safety concern. One dealer told me, he can't do anything unless it's acting up as they are troubleshooting it and the codes mean nothing to him! I am getting really aggrevated with the run around!
If you have contacted Chrysler already, they should force the issue with the dealer and make sure it gets fixed. What you're saying doesn't make sense. The Chrysler rep should be telling the dealer what to do, and then they have no choice but to do it.
 

·
Registered
Joined
·
3 Posts
P Trumper

I too have had problems with my 2012 durango (crew), VERY SERIOUS PROBLEMSwith the computer!! Complete vehicle shutdown and down shifting into 1st gear while on frwy driving 65 mph! no help with Dealership or dodge corp! vehicle can't be driven as no insurance company will insure the vehicle !!! :kap:
I have a two week old 2012 Durango Crew with 500 miles so far. I have noticed some odd things here and there but Friday things started getting strange.

Upon returning to the car after running into a store Friday night and starting the engine the dash and headlights failed to turn on. Also could not get dome lights to turn on. Stopping the engine, getting out, locking, unlocking several times the lights finally came on but the engine light stayed on, long with the traction control light. PushIng traction control button turned that light off. While driving, though, ECO light never lit even while coasting.

Saturday after a few drives everything went back to normal. However, that night I remote started and after entering and starting to drive the front wipers came on by themselves. No matter what they would not stop or even change speeds. Could not use washer to try and protect blades. Engine light on, traction light on, no dome lights, no turn indicators, dash menu frozen, no ECO light. Ended up removing wiper fuse. Still that way today after several drives.

Will take it to dealer service tomorrow. Seems like the 'computer' needs to be reset/reloaded. Anyone ever heard of this or have any ideas?
 

·
Registered
Joined
·
3 Posts
P Trumper

If you have contacted Chrysler already, they should force the issue with the dealer and make sure it gets fixed. What you're saying doesn't make sense. The Chrysler rep should be telling the dealer what to do, and then they have no choice but to do it.
I've contacted Dodge Corp. and they are ZERO help!! My Durango has been at the dealership for over a month, and they told me the same thing (can't find the problem can't or wont fixit)!!! I've had to rent a vehicle because they won't provide a loaner. NO INSURACE COMPANY WILL INSURE THIS VEHICLE as it is a danger to me and the public safety!!! Dodge is telling me to drive it until it happens again!!
 
1 - 9 of 9 Posts
Top