Dodge Durango Forum - Forums and Owners Club! banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone! I just got a 2012 durango crew v6 in January. Its my first American car ever.. after just 3000 miles a light just came on saying "service All-wheel drive." I made an appointment with the dealer and havent noticed anything different while driving.. anyone else have this issue? something to worry about??
 

·
Administrator
2009 Dodge Challenger R/T
Joined
·
2,566 Posts
I'm guessing that it's in the programming of the pcm. May want to take a peek in your owners manual at the service requirements and see if that's one of them.
 

·
Registered
Joined
·
2,005 Posts
From the 2012 Durango User Guide:

"The “SERV AWD Warning Light” monitors the electronic shift all-wheel drive
system. If this light remains on after engine start up or illuminates during driving, it
means that the all-wheel drive system is not functioning properly and that service is​
required."

Always engage the parking brake when powering
down the vehicle if the “SERV AWD Warning Light”
is illuminated. Not engaging the parking brake may
allow the vehicle to roll which may cause personal​
injury.

Get it to the dealer.
 

·
Registered
Joined
·
2 Posts
Not under warranty. bought salvage title with hail damage otherwise that sucker would be sitting at dodge right now. Im trying to determine if this is a serious issue or just a fluke sensitive sensor. drove from Michigan to California and only came on twice. When I restart it, its off.

any advice appreciated.
 

·
Registered
Joined
·
1 Posts
Hello everyone,
I have the same issue before. And it came back 2 days ago. Wheb this light comes up itmeans u r driving on 2w which is the back wheels only. And the awd sincer is not working it cost about $1,000. It was under the warranty. To test it do a burn out break and gas" I bought an extended warranty program and im waiting for my appointment to fix it. U can drive ur car and u will notice it lighter than befor. I will take a pic of the invoice to tells u what is the part name once i get my car.
 

·
Registered
Joined
·
1 Posts
How to use site

anyone know it there are any instructions on how to post a thread on this site have been looking forever..... this is the only tab I have found to post anything... and yes I know I am intruding on someones post.......
 

·
Registered
Joined
·
1 Posts
servjce awd warning

Not under warranty. bought salvage title with hail damage otherwise that sucker would be sitting at dodge right now. Im trying to determine if this is a serious issue or just a fluke sensitive sensor. drove from Michigan to California and only came on twice. When I restart it, its off.

any advice appreciated.
i also had that problem mine did also come on once in a while and reset itself after shut off car and restart.found out it was front axel actuator went bad cost me just under 500.00 to replace it. Good luck !:smiley_thumbs
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top